What’s Vulnerable › Vulnerabilities
CVE-2026-28560: wpForo Forum 2.4.14 Stored XSS via Unsafe JSON Encoding in Inline Script
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
wpForo Forum 2.4.14 contains a stored cross-site scripting vulnerability that allows script injection via forum URL data output into an inline script block using json_encode without the JSON_HEX_TAG flag. Attackers set a forum slug containing a closing script tag or unescaped single quote to break out of the JavaScript string context and execute arbitrary script in all visitors' browsers.
Affected products
- tomdever wpForo Forum: from 2.4.0 before 2.4.16 — fixed in 2.4.16
How to fix
Upgrade to a fixed version: tomdever wpForo Forum 2.4.16. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/wpforo/
- https://wordpress.org/plugins/wpforo/#developers
- https://www.vulncheck.com/advisories/wpforo-forum-stored-xss-via-unsafe-json-encoding-in-inline-script
Get alerted when CVE-2026-28560 or the next vulnerability affects your stack