What’s Vulnerable › Vulnerabilities
CVE-2026-28563: Apache Airflow: DAG authorization bypass
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-17 · updated 2026-06-17
- Weakness: CWE-732
Description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
Affected products
- Apache Airflow: from 3.0.0 before 3.1.8 — fixed in 3.1.8
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/62046
- https://lists.apache.org/thread/dwzf62qg9z8wvfsjknpfd8bvtwghd49s
- http://www.openwall.com/lists/oss-security/2026/03/17/5
Get alerted when CVE-2026-28563 or the next vulnerability affects your stack