What’s Vulnerable › Vulnerabilities
CVE-2026-28673: xiaoheiFS Vulnerable to RCE via Unrestricted Plugin Installation (Manifest Manipulation)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-78
Description
xiaoheiFS is a self-hosted financial and operational system for cloud service businesses. In versions up to and including 0.3.15, the standard plugin system allows admins to upload a ZIP file containing a binary and a `manifest.json`. The server trusts the `binaries` field in the manifest and executes the specified file without any validation of its contents or behavior, leading to Remote Code Execution (RCE). Version 0.4.0 fixes the issue.
Affected products
- danvei233 xiaoheiFS: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: danvei233 xiaoheiFS 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/danvei233/xiaoheiFS/security/advisories/GHSA-4vw4-5wmh-7x4v
- https://github.com/danvei233/xiaoheiFS/security/advisories/GHSA-4vw4-5wmh-7x4v
Get alerted when CVE-2026-28673 or the next vulnerability affects your stack