What’s Vulnerable › Vulnerabilities
CVE-2026-28693: ImageMagick has an integer overflow in DIB coder can result in out of bounds read or write
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-07-15
- Weakness: CWE-125
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, an integer overflow in DIB coder can result in out of bounds read or write. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
Affected products
- ImageMagick: before 6.9.13-41; from 7.0.0-0 before 7.1.2-16 — fixed in 6.9.13-41, 7.1.2-16
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-41, 7.1.2-16. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-hffp-q43q-qq76
- https://access.redhat.com/errata/RHSA-2026:6713
- https://access.redhat.com/security/cve/CVE-2026-28693
- https://bugzilla.redhat.com/show_bug.cgi?id=2445888
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28693.json
Get alerted when CVE-2026-28693 or the next vulnerability affects your stack