What’s Vulnerable › Vulnerabilities

CVE-2026-28735: GitHub OAuth Scope Validation

Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate the OAuth token scope on the callback which allows an authenticated Mattermost user to gain access to private repositories via modifying the scope parameter in the GitHub authorization URL.. Mattermost Advisory ID: MMSA-2026-00628

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.15, 11.4.5, 11.5.4, 11.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-28735 or the next vulnerability affects your stack