What’s Vulnerable › Vulnerabilities
CVE-2026-28753: NGINX ngx_mail_proxy_module vulnerability
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-93
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_mail_smtp_module module due to the improper handling of CRLF sequences in DNS responses. This allows an attacker-controlled DNS server to inject arbitrary headers into SMTP upstream requests, leading to potential request manipulation. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 0.6.27 through 0.9.7; from 1.0.0 before 1.28.3; from 1.29.0 before 1.29.7 — fixed in 1.28.3, 1.29.7
- F5 NGINX Plus: r32-p1, r32-p2, r32-p3, r32-p4, r33, r33-p1 (+10)
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.28.3, 1.29.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-28753 or the next vulnerability affects your stack