What’s Vulnerable › Vulnerabilities
CVE-2026-28755: NGINX ngx_stream_ssl_module vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-24 · updated 2026-06-17
- Weakness: CWE-863
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_stream_ssl_module module due to the improper handling of revoked certificates when configured with the ssl_verify_client on and ssl_ocsp on directives, allowing the TLS handshake to succeed even after an OCSP check identifies the certificate as revoked. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 0.5.13 through 0.9.7; from 1.27.2 before 1.28.3; from 1.29.0 before 1.29.7 — fixed in 1.28.3, 1.29.7
- F5 NGINX Plus: r33, r33-p1, r33-p2, r33-p3, r34, r34-p1 (+5)
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.28.3, 1.29.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-28755 or the next vulnerability affects your stack