What’s Vulnerable › Vulnerabilities
CVE-2026-28780: Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-05 · updated 2026-09-14
- Weakness: CWE-122
Description
Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
Affected products
- Apache HTTP Server: before 2.4.67 — fixed in 2.4.67
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.67. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/05/05/9
- https://access.redhat.com/errata/RHSA-2026:21391
- https://access.redhat.com/errata/RHSA-2026:21433
- https://access.redhat.com/errata/RHSA-2026:22140
- https://access.redhat.com/errata/RHSA-2026:27200
- https://access.redhat.com/errata/RHSA-2026:27201
- https://access.redhat.com/errata/RHSA-2026:36373
- https://access.redhat.com/errata/RHSA-2026:36831
- https://access.redhat.com/errata/RHSA-2026:36846
- https://access.redhat.com/errata/RHSA-2026:47046
- https://access.redhat.com/errata/RHSA-2026:62165
Get alerted when CVE-2026-28780 or the next vulnerability affects your stack