What’s Vulnerable › Vulnerabilities
CVE-2026-2880: @fastify/middie has an improper path normalization vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-27 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in @fastify/middie versions < 9.2.0 can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)). When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers.
Affected products
- fastify middie: before 9.2.0 — fixed in 9.2.0
How to fix
Upgrade to a fixed version: fastify middie 9.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2880 or the next vulnerability affects your stack