What’s Vulnerable › Vulnerabilities
CVE-2026-28811: Apache JSPWiki: Error Handling - Reveals Error Details
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-1295
Description
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.4 — fixed in 2.12.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.4. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2026-28811
- https://lists.apache.org/thread/2dm414zzjo3pvhjz6mvqy3b5yhvnkcg5
- http://www.openwall.com/lists/oss-security/2026/07/30/14
Get alerted when CVE-2026-28811 or the next vulnerability affects your stack