What’s Vulnerable › Vulnerabilities
CVE-2026-28812: Apache JSPWiki: UserManager does not sanity-check user database at startup
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-290
Description
UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate privileges. Users are recommended to upgrade to version 2.12.4 or newer which fixes this issue.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.4 — fixed in 2.12.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n3m666d6t6871dldvz3ct49ooqkbgw2p
- http://www.openwall.com/lists/oss-security/2026/07/30/15
Get alerted when CVE-2026-28812 or the next vulnerability affects your stack