What’s Vulnerable › Vulnerabilities

CVE-2026-28814: Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering

Description

Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables. Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-28814 or the next vulnerability affects your stack