What’s Vulnerable › Vulnerabilities
CVE-2026-28894
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-20
Description
A denial-of-service issue was addressed with improved input validation. This issue is fixed in iOS 26.4 and iPadOS 26.4, macOS Sequoia 15.7.5, macOS Sonoma 14.8.5, macOS Tahoe 26.4. A remote attacker may be able to cause a denial-of-service.
Affected products
- Apple iPadOS: before 26.4 — fixed in 26.4
- Apple Iphone Os: before 26.4 — fixed in 26.4
- Apple macOS: from 14.0 before 14.8.5; from 15.0 before 15.7.5; from 26.0 before 26.4 — fixed in 14.8.5, 15.7.5, 26.4
How to fix
Upgrade to a fixed version: Apple iPadOS 26.4; Apple Iphone Os 26.4; Apple macOS 14.8.5, 15.7.5, 26.4. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/126792
- https://support.apple.com/en-us/126794
- https://support.apple.com/en-us/126795
- https://support.apple.com/en-us/126796
Get alerted when CVE-2026-28894 or the next vulnerability affects your stack