What’s Vulnerable › Vulnerabilities

CVE-2026-29000: pac4j-jwt JwtAuthenticator Authentication Bypass

Description

pac4j-jwt versions prior to 4.5.9, 5.7.9, and 6.3.3 contain an authentication bypass vulnerability in JwtAuthenticator when processing encrypted JWTs that allows remote attackers to forge authentication tokens. Attackers who possess the server's RSA public key can create a JWE-wrapped PlainJWT with arbitrary subject and role claims, bypassing signature verification to authenticate as any user including administrators.

Affected products

How to fix

Upgrade to a fixed version: pac4j-jwt 4.5.9, 5.7.9, 6.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-29000 or the next vulnerability affects your stack