What’s Vulnerable › Vulnerabilities
CVE-2026-29068: PJSIP: Stack buffer overflow in Opus codec parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-121
Description
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, there is a stack buffer overflow vulnerability when pjmedia-codec parses an RTP payload contain more frames than the caller-provided frames can hold. This issue has been patched in version 2.17.
Affected products
- Pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/6c9024511bf5307ff72efde1f90c9a2a226d8967
- https://github.com/pjsip/pjproject/security/advisories/GHSA-pqww-jrxr-457f
Get alerted when CVE-2026-29068 or the next vulnerability affects your stack