What’s Vulnerable › Vulnerabilities
CVE-2026-29089: TimescaleDB uses untrusted search path during extension upgrade
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-426
Description
TimescaleDB is a time-series database for high-performance real-time analytics packaged as a Postgres extension. From version 2.23.0 to 2.25.1, PostgreSQL uses the search_path setting to locate unqualified database objects (tables, functions, operators). If the search_path includes user-writable schemas a malicious user can create functions in that schema that shadow builtin postgres functions and will be called instead of the postgres functions leading to arbitrary code execution during extension upgrade. This issue has been patched in version 2.25.2.
Affected products
- timescaledb: from 2.23.0 before 2.25.2 — fixed in 2.25.2
How to fix
Upgrade to a fixed version: timescaledb 2.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/timescale/timescaledb/commit/9a8f7f8bdeb99e6abae0786ffe526791a8628ce3
- https://github.com/timescale/timescaledb/pull/9331
- https://github.com/timescale/timescaledb/releases/tag/2.25.2
- https://github.com/timescale/timescaledb/security/advisories/GHSA-vgp2-jj5c-828m
Get alerted when CVE-2026-29089 or the next vulnerability affects your stack