What’s Vulnerable › Vulnerabilities
CVE-2026-29091: Locutus: Remote Code Execution (RCE) in locutus call_user_func_array due to Code Injection
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-06 · updated 2026-07-15
- Weakness: CWE-95
Description
Locutus brings stdlibs of other programming languages to JavaScript for educational purposes. Prior to version 3.0.0, a remote code execution (RCE) flaw was discovered in the locutus project, specifically within the call_user_func_array function implementation. The vulnerability allows an attacker to inject arbitrary JavaScript code into the application's runtime environment. This issue stems from an insecure implementation of the call_user_func_array function (and its wrapper call_user_func), which fails to properly validate all components of a callback array before passing them to eval(). This issue has been patched in version 3.0.0.
Affected products
- locutusjs locutus: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: locutusjs locutus 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/locutusjs/locutus/commit/977a1fb169441e35996a1d2465b512322de500ad
- https://github.com/locutusjs/locutus/security/advisories/GHSA-fp25-p6mj-qqg6
- https://access.redhat.com/security/cve/CVE-2026-29091
- https://bugzilla.redhat.com/show_bug.cgi?id=2445262
- https://github.com/locutusjs/locutus/security/advisories/GHSA-fp25-p6mj-qqg6
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29091.json
Get alerted when CVE-2026-29091 or the next vulnerability affects your stack