What’s Vulnerable › Vulnerabilities
CVE-2026-29111: systemd: Local unprivileged user can trigger an assert
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-269
Description
systemd, a system and service manager, (as PID 1) hits an assert and freezes execution when an unprivileged IPC API call is made with spurious data. On version v249 and older the effect is not an assert, but stack overwriting, with the attacker controlled content. From version v250 and newer this is not possible as the safety check causes an assert instead. This IPC call was added in v239, so versions older than that are not affected. Versions 260-rc1, 259.2, 258.5, and 257.11 contain patches. No known workarounds are available.
Affected products
- systemd: from 239 before 257.11; from 258 before 258.5; from 259 before 259.2 — fixed in 257.11, 258.5, 259.2
How to fix
Upgrade to a fixed version: systemd 257.11, 258.5, 259.2. Check the vendor advisory for mitigations.
References
- https://github.com/systemd/systemd/commit/1d22f706bd04f45f8422e17fbde3f56ece17758a
- https://github.com/systemd/systemd/commit/20021e7686426052e3a7505425d7e12085feb2a6
- https://github.com/systemd/systemd/commit/21167006574d6b83813c7596759b474f56562412
- https://github.com/systemd/systemd/commit/3cee294fe8cf4fa0eff933ab21416d099942cabd
- https://github.com/systemd/systemd/commit/42aee39107fbdd7db1ccd402a2151822b2805e9f
- https://github.com/systemd/systemd/commit/54588d2dedff54bfb6036670820650e4ea74628f
- https://github.com/systemd/systemd/commit/7ac3220213690e8a8d6d2a6e81e43bd1dce01d69
- https://github.com/systemd/systemd/commit/80acea4ef80a4bb78560ed970c34952299b890d6
- https://github.com/systemd/systemd/commit/b5fd14693057e5f2c9b4a49603be64ec3608ff6c
- https://github.com/systemd/systemd/commit/efa6ba2ab625aaa160ac435a09e6482fc63bdbe8
- https://github.com/systemd/systemd/security/advisories/GHSA-gx6q-6f99-m764
Get alerted when CVE-2026-29111 or the next vulnerability affects your stack