What’s Vulnerable › Vulnerabilities
CVE-2026-29112: @dicebear/converter vulnerable to ncontrolled memory allocation via crafted SVG dimensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-770
Description
DiceBear is an avatar library for designers and developers. Prior to version 9.4.0, the `ensureSize()` function in `@dicebear/converter` read the `width` and `height` attributes from the input SVG to determine the output canvas size for rasterization (PNG, JPEG, WebP, AVIF). An attacker who can supply a crafted SVG with extremely large dimensions (e.g. `width="999999999"`) could force the server to allocate excessive memory, leading to denial of service. This primarily affects server-side applications that pass untrusted or user-supplied SVGs to the converter's `toPng()`, `toJpeg()`, `toWebp()`, or `toAvif()` functions. Applications that only convert self-generated DiceBear avatars are not practically exploitable, but are still recommended to upgrade. This is fixed in version 9.4.0. The `ensureSize()` function no longer reads SVG attributes to determine output size. Instead, a new `size` option (default: 512, max: 2048) controls the output dimensions. Invalid values (NaN, negative, zero, Infinity) fall back to the default. If upgrading is not immediately possible, validate and sanitize the `width` and `height` attributes of any untrusted SVG input before passing it to the converter.
Affected products
- dicebear: before 9.4.0 — fixed in 9.4.0
How to fix
Upgrade to a fixed version: dicebear 9.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/dicebear/dicebear/commit/42a59eac46a3c68598859e608ec45e578b27614a
- https://github.com/dicebear/dicebear/releases/tag/v9.4.0
- https://github.com/dicebear/dicebear/security/advisories/GHSA-v3r3-4qgc-vw66
Get alerted when CVE-2026-29112 or the next vulnerability affects your stack