What’s Vulnerable › Vulnerabilities

CVE-2026-29129: Apache Tomcat: TLS cipher order is not preserved

Description

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 9.0.116, 10.1.53, 11.0.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-29129 or the next vulnerability affects your stack