What’s Vulnerable › Vulnerabilities
CVE-2026-29169: Apache HTTP Server: mod_dav_lock indirect lock crash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-25
- Weakness: CWE-476
Description
A NULL pointer dereference in mod_dav_lock in Apache HTTP Server 2.4.66 and earlier may allow an attacker to crash the server with a malicious request.mod_dav_lock is not used internally by mod_dav or mod_dav_fs. The only known use-case for mod_dav_lock was mod_dav_svn from Apache Subversion earlier than version 1.2.0. Users are recommended to upgrade to version 2.4.66, which fixes this issue, or remove mod_dav_lock.
Affected products
- Apache HTTP Server: before 2.4.67 — fixed in 2.4.67
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.67. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/05/04/20
- http://www.openwall.com/lists/oss-security/2026/05/05/12
Get alerted when CVE-2026-29169 or the next vulnerability affects your stack