What’s Vulnerable › Vulnerabilities
CVE-2026-29170: Apache HTTP Server: mod_proxy_ftp XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-08 · updated 2026-07-23
- Weakness: CWE-79
Description
A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue.
Affected products
- Apache HTTP Server: before 2.4.68 — fixed in 2.4.68
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.68. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/06/08/5
Get alerted when CVE-2026-29170 or the next vulnerability affects your stack