What’s Vulnerable › Vulnerabilities
CVE-2026-29178: Lemmy: Unauthenticated SSRF via file_type query parameter injection in image endpoint
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-918
Description
Lemmy, a link aggregator and forum for the fediverse, is vulnerable to server-side request forgery via a dependency on activitypub_federation, a framework for ActivityPub federation in Rust. Prior to version 0.19.16, the GET /api/v4/image/{filename} endpoint is vulnerable to unauthenticated SSRF through parameter injection in the file_type query parameter. An attacker can inject arbitrary query parameters into the internal request to pict-rs, including the proxy parameter which causes pict-rs to fetch arbitrary URLs. This issue has been patched in version 0.19.16.
Affected products
- LemmyNet lemmy: before 0.19.16
References
- https://github.com/LemmyNet/lemmy/commit/f47a03f56d1797bceab5f34b6f624c91cecd5871
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-jvxv-2jjp-jxc3
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-jvxv-2jjp-jxc3
Get alerted when CVE-2026-29178 or the next vulnerability affects your stack