What’s Vulnerable › Vulnerabilities
CVE-2026-29187: OpenEMR Vulnerable to Authenticated Blind Boolean-Based SQL Injection in new_search_popup.php
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0.3, a Blind SQL Injection vulnerability exists in the Patient Search functionality (/interface/new/new_search_popup.php). The vulnerability allows an authenticated attacker to execute arbitrary SQL commands by manipulating the HTTP parameter keys rather than the values. Version 8.0.0.3 contains a patch.
Affected products
- openemr: before 8.0.0.3 — fixed in 8.0.0.3
How to fix
Upgrade to a fixed version: openemr 8.0.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/c61887aa7c83e83b3282db05246f1c00de3aa21d
- https://github.com/openemr/openemr/releases/tag/v8_0_0_3
- https://github.com/openemr/openemr/security/advisories/GHSA-2r7h-xm8v-m872
Get alerted when CVE-2026-29187 or the next vulnerability affects your stack