What’s Vulnerable › Vulnerabilities

CVE-2026-29197

Description

In versions <8.4.0, <8.3.2, <8.2.2, <8.1.3, <8.0.4, <7.13.6, <7.12.7, <7.11.7, and <7.10.10, the endpoints /api/apps/logs and /api/apps/:id/logs have a typo in the required permission check, allowing authenticated users without the proper permissions to read apps-engine logs.

Affected products

How to fix

Upgrade to a fixed version: Rocket.Chat 7.10.10, 7.11.7, 7.12.7, 7.13.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-29197 or the next vulnerability affects your stack