What’s Vulnerable › Vulnerabilities
CVE-2026-29198
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-23 · updated 2026-10-23
- Weakness: CWE-89
Description
In Rocket.Chat <8.3.0, <8.2.1, <8.1.2, <8.0.3, <7.13.5, <7.12.6, <7.11.6, and <7.10.9, a NoSQL injection vulnerability can lead to account takeover of the first user with a generated token when an OAuth app is configured.
Affected products
- Rocket.Chat: before 7.10.9; from 7.11.0 before 7.11.6; from 7.12.0 before 7.12.6; from 7.13.0 before 7.13.5; from 8.0.0 before 8.0.3; from 8.1.0 before 8.1.2 — fixed in 7.10.9, 7.11.6, 7.12.6, 7.13.5, 8.0.3, 8.1.2
How to fix
Upgrade to a fixed version: Rocket.Chat 7.10.9, 7.11.6, 7.12.6, 7.13.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-29198 or the next vulnerability affects your stack