What’s Vulnerable › Vulnerabilities
CVE-2026-29199
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-06-17
- Weakness: CWE-640
Description
phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning. When force_server_vars is disabled, the servers hostname may be extracted from the HTTP Host header which is used to generate the password reset link URL. An attacker who can manipulate the Host header (e.g. through misconfigured host setup or missing header validation by the webserver) can cause password reset emails to contain a link pointing to an attacker-controlled domain, potentially leading to account takeover.
Affected products
- phpBB: before 3.3.16 — fixed in 3.3.16
How to fix
Upgrade to a fixed version: phpBB 3.3.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-29199 or the next vulnerability affects your stack