What’s Vulnerable › Vulnerabilities
CVE-2026-29205
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-250
Description
Incorrect privileges management and insufficient path filtering allow to read arbitrary file on the server via the cpdavd attachment download endpoints.
Affected products
- WebPros cPanel: from 120.0.0 before 124.0.38; from 126.0.0 before 126.0.59; from 130.0.0 before 130.0.23; from 130.0.23 before 130.0.23; from 132.0.0 before 132.0.32; from 134.0.0 before 134.0.26 — fixed in 124.0.38, 126.0.59, 130.0.23, 132.0.32, 134.0.26, 136.0.10
- WebPros WHM: from 120.0.0 before 124.0.38; from 126.0.0 before 126.0.59; from 130.0.0 before 130.0.23; from 132.0.0 before 132.0.32; from 134.0.0 before 134.0.26; from 136.0.0 before 136.0.10 — fixed in 124.0.38, 126.0.59, 130.0.23, 132.0.32, 134.0.26, 136.0.10
- WebPros WP Squared: from 120.1.0 before 136.1.12 — fixed in 136.1.12
How to fix
Upgrade to a fixed version: WebPros cPanel 124.0.38, 126.0.59, 130.0.23, 132.0.32; WebPros WHM 124.0.38, 126.0.59, 130.0.23, 132.0.32; WebPros WP Squared 136.1.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-29205 or the next vulnerability affects your stack