What’s Vulnerable › Vulnerabilities
CVE-2026-29207: Apache OFBiz: Low-Privilege SSTI Leading to RCE in the Content Component
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-10-14
- Weakness: CWE-1336
Description
Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 24.09.06. Users are recommended to upgrade to version 24.09.06, which fixes the issue. Please note that in the updated version, "Data Resource" records with dataTemplateTypeId = "FTL" are no longer supported. Additionally, in the updated version, the "Ecommerce Customer" security group no longer includes content management grants. Users are advised to remove these permissions from any production site as well.
Affected products
- Apache Software Foundation Apache OFBiz: before 24.09.06 — fixed in 24.09.06
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 24.09.06. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/3rcrp8bh3x6ovrj5xnc0fm1f0nrn52r0
- http://www.openwall.com/lists/oss-security/2026/05/19/14
Get alerted when CVE-2026-29207 or the next vulnerability affects your stack