What’s Vulnerable › Vulnerabilities
CVE-2026-2950: lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-10-15
- Weakness: CWE-1321
Description
The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype. The issue permits deletion of prototype properties but does not allow overwriting their original behavior. The issue is patched from 4.18.0 to 4.18.1 depending on the package: lodash, lodash-es, and lodash-amd in 4.18.1, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
Affected products
- lodash: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- lodash-amd: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- lodash-es: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- lodash.unset: from 4.0.0
- Npm Lodash: before 4.18.0 — fixed in 4.18.0
- Npm Lodash-Amd: before 4.18.0 — fixed in 4.18.0
- Npm Lodash-Es: before 4.18.0 — fixed in 4.18.0
- Npm Lodash.Unset: from 4.0.0 before 4.18.0 — fixed in 4.18.0
How to fix
Upgrade to a fixed version: lodash 4.17.23; lodash-amd 4.17.23; lodash-es 4.17.23; Npm Lodash 4.18.0; Npm Lodash-Amd 4.18.0; Npm Lodash-Es 4.18.0; Npm Lodash.Unset 4.18.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/lodash/lodash/security/advisories/GHSA-f23m-r3pf-42rh
Get alerted when CVE-2026-2950 or the next vulnerability affects your stack