What’s Vulnerable › Vulnerabilities
CVE-2026-29607: OpenClaw < 2026.2.22 - Authorization Bypass via allow-always Wrapper Persistence
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-78
Description
OpenClaw versions prior to 2026.2.22 contain an authorization bypass vulnerability in allow-always wrapper persistence that allows attackers to bypass approval checks by persisting wrapper-level allowlist entries instead of validating inner executable intent. Remote attackers can approve benign wrapped system.run commands and subsequently execute different payloads without approval, enabling remote code execution on gateway and node-host execution flows.
Affected products
- OpenClaw: before 2026.2.22 — fixed in 2026.2.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/24c954d972400f508814532dea0e4dcb38418bb0
- https://github.com/openclaw/openclaw/security/advisories/GHSA-6j27-pc5c-m8w8
- https://www.vulncheck.com/advisories/openclaw-authorization-bypass-via-allow-always-wrapper-persistence
Get alerted when CVE-2026-29607 or the next vulnerability affects your stack