What’s Vulnerable › Vulnerabilities
CVE-2026-29610: OpenClaw < 2026.2.14 - Command Hijacking via Unsafe PATH Handling
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-427
Description
OpenClaw versions prior to 2026.2.14 contain a command hijacking vulnerability that allows attackers to execute unintended binaries by manipulating PATH environment variables through node-host execution or project-local bootstrapping. Attackers with authenticated access to node-host execution surfaces or those running OpenClaw in attacker-controlled directories can place malicious executables in PATH to override allowlisted safe-bin commands and achieve arbitrary command execution.
Affected products
- OpenClaw: before 2026.2.14 — fixed in 2026.2.14
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.14. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/013e8f6b3be3333a229a066eef26a45fec47ffcc
- https://github.com/openclaw/openclaw/security/advisories/GHSA-jqpq-mgvm-f9r6
- https://www.vulncheck.com/advisories/openclaw-command-hijacking-via-unsafe-path-handling
Get alerted when CVE-2026-29610 or the next vulnerability affects your stack