What’s Vulnerable › Vulnerabilities
CVE-2026-2973: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to execute arbitrary JavaScript in a user's browser due to improper sanitization of entity-encoded content in Mermaid diagrams.
Affected products
- GitLab: from 17.7.0 before 18.8.7; from 18.9.0 before 18.9.3; 18.10.0 — fixed in 18.8.7, 18.9.3
How to fix
Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/03/25/patch-release-gitlab-18-10-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/591049
- https://hackerone.com/reports/3566802
Get alerted when CVE-2026-2973 or the next vulnerability affects your stack