What’s Vulnerable › Vulnerabilities
CVE-2026-29785: NATS Server panic via malicious compression on leafnode port
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-09-09
- Weakness: CWE-476
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.14 and 2.12.5, if the nats-server has the "leafnode" configuration enabled (not default), then anyone who can connect can crash the nats-server by triggering a panic. This happens pre-authentication and requires that compression be enabled (which it is, by default, when leafnodes are used). Versions 2.11.14 and 2.12.5 contain a fix. As a workaround, disable compression on the leafnode port.
Affected products
- nats-io nats-server: before 2.11.14; from 2.12.0 before 2.12.5 — fixed in 2.11.14, 2.12.5
How to fix
Upgrade to a fixed version: nats-io nats-server 2.11.14, 2.12.5. Check the vendor advisory for mitigations.
References
- https://advisories.nats.io/CVE/secnote-2026-04.txt
- https://github.com/nats-io/nats-server/commit/a1488de6f2ba6e666aef0f9cce0016f7f167d6a8
- https://github.com/nats-io/nats-server/security/advisories/GHSA-52jh-2xxh-pwh6
- https://access.redhat.com/errata/RHSA-2026:21769
- https://access.redhat.com/errata/RHSA-2026:22347
- https://access.redhat.com/errata/RHSA-2026:23345
- https://access.redhat.com/security/cve/CVE-2026-29785
- https://bugzilla.redhat.com/show_bug.cgi?id=2451444
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29785.json
Get alerted when CVE-2026-29785 or the next vulnerability affects your stack