What’s Vulnerable › Vulnerabilities

CVE-2026-2994: Concrete CMS below 9.4.8 is vulnerable to CSRF by a Rogue Admin using the Anti-Spam Allowlist Group

Description

Concrete CMS below version 9.4.8 is subject to CSRF by a Rogue Administrator using the Anti-Spam Allowlist Group Configuration via group_id parameter which can leads to a security bypass since changes are saved prior to checking the CSRF token. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks z3rco for reporting

Affected products

How to fix

Upgrade to a fixed version: Concrete CMS 9.4.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2994 or the next vulnerability affects your stack