What’s Vulnerable › Vulnerabilities
CVE-2026-3058: Seraphinite Accelerator <= 2.28.14 - Authenticated (Subscriber+) Exposure of Sensitive Information to an Unauthorized Actor
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-200
Description
The Seraphinite Accelerator plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.28.14 via the `seraph_accel_api` AJAX action with `fn=GetData`. This is due to the `OnAdminApi_GetData()` function not performing any capability checks. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve sensitive operational data including cache status, scheduled task information, and external database state.
Affected products
- seraphinitesoft Seraphinite Accelerator: before 2.28.15 — fixed in 2.28.15
How to fix
Upgrade to a fixed version: seraphinitesoft Seraphinite Accelerator 2.28.15. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/seraphinite-accelerator/trunk/Cmn/Plugin.php#L598
- https://plugins.trac.wordpress.org/browser/seraphinite-accelerator/trunk/main.php#L2288
- https://plugins.trac.wordpress.org/changeset/3468084/seraphinite-accelerator/trunk/main.php?contextall=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bf539c01-596a-44dd-9587-6be6978ab0fa?source=cve
Get alerted when CVE-2026-3058 or the next vulnerability affects your stack