What’s Vulnerable › Vulnerabilities
CVE-2026-30778: Apache SkyWalking: The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-202
Description
The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL. This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0. Users are recommended to upgrade to version 10.4.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache SkyWalking: from 9.7.0 before 10.4.0 — fixed in 10.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache SkyWalking 10.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/pvf35o3tp1rqhmrhzj6fg31gvqrqcvn3
- http://www.openwall.com/lists/oss-security/2026/04/15/2
Get alerted when CVE-2026-30778 or the next vulnerability affects your stack