What’s Vulnerable › Vulnerabilities
CVE-2026-30835: Parse Server: Malformed `$regex` query leaks database error details in API response
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-209
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.7 and 9.5.0-alpha.6, malformed $regex query parameter (e.g. [abc) causes the database to return a structured error object that is passed unsanitized through the API response. This leaks database internals such as error messages, error codes, code names, cluster timestamps, and topology details. The vulnerability is exploitable by any client that can send query requests, depending on the deployment's permission configuration. This issue has been patched in versions 8.6.7 and 9.5.0-alpha.6.
Affected products
- parse-community parse-server: before 8.6.7; from 9.0.0 before 9.5.0; 9.5.0-alpha1, 9.5.0-alpha2, 9.5.0-alpha3, 9.5.0-alpha4, 9.5.0-alpha5 — fixed in 8.6.7, 9.5.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.7, 9.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.7
- https://github.com/parse-community/parse-server/releases/tag/9.5.0-alpha.6
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9cp7-3q5w-j92g
Get alerted when CVE-2026-30835 or the next vulnerability affects your stack