What’s Vulnerable › Vulnerabilities
CVE-2026-3084: GStreamer H.266 Codec Parser Integer Underflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-07-15
- Weakness: CWE-191
Description
GStreamer H.266 Codec Parser Integer Underflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of picture partitions. The issue results from the lack of proper validation of user-supplied data, which can result in an integer underflow before writing to memory. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28910.
Affected products
- GStreamer: before 1.28.1 — fixed in 1.28.1
How to fix
Upgrade to a fixed version: GStreamer 1.28.1. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/496e4f296e658fba7fd40027d3bbe6095633ec91
- https://www.zerodayinitiative.com/advisories/ZDI-26-169/
- https://access.redhat.com/security/cve/CVE-2026-3084
- https://bugzilla.redhat.com/show_bug.cgi?id=2447483
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-3084.json
Get alerted when CVE-2026-3084 or the next vulnerability affects your stack