What’s Vulnerable › Vulnerabilities
CVE-2026-30862: Critical Stored XSS & Privilege Escalation in Appsmith
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Appsmith is a platform to build admin panels, internal tools, and dashboards. Prior to 1.96, a Critical Stored XSS vulnerability exists in the Table Widget (TableWidgetV2). The root cause is a lack of HTML sanitization in the React component rendering pipeline, allowing malicious attributes to be interpolated into the DOM. By leveraging the "Invite Users" feature, an attacker with a regular user account (user@gmail.com) can force a System Administrator to execute a high-privileged API call (/api/v1/admin/env), resulting in a Full Administrative Account Takeover. This vulnerability is fixed in 1.96.
Affected products
- appsmithorg appsmith: before 1.96 — fixed in 1.96
How to fix
Upgrade to a fixed version: appsmithorg appsmith 1.96. Check the vendor advisory for mitigations.
References
- https://github.com/appsmithorg/appsmith/security/advisories/GHSA-5hw4-whxv-6794
- https://github.com/appsmithorg/appsmith/security/advisories/GHSA-5hw4-whxv-6794
Get alerted when CVE-2026-30862 or the next vulnerability affects your stack