What’s Vulnerable › Vulnerabilities
CVE-2026-30868: Cross-Site Request Forgery (CSRF) in opnsense/core
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-352
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.4, multiple OPNsense MVC API endpoints perform state‑changing operations but are accessible via HTTP GET requests without CSRF protection. The framework CSRF validation in ApiControllerBase only applies to POST/PUT/DELETE methods, allowing authenticated GET requests to bypass CSRF verification. As a result, a malicious website can trigger privileged backend actions when visited by an authenticated user, causing unintended service reloads and configuration changes through configd. This results in an authenticated Cross‑Site Request Forgery vulnerability allowing unauthorized system state changes. This vulnerability is fixed in 26.1.4.
Affected products
- OPNsense: before 26.1.4 — fixed in 26.1.4
How to fix
Upgrade to a fixed version: OPNsense 26.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-30868 or the next vulnerability affects your stack