What’s Vulnerable › Vulnerabilities
CVE-2026-30874: OpenWrt procd PATH Environment Variable Filter Bypass via Incorrect String Comparison Leads to Privilege Escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-74
Description
OpenWrt Project is a Linux operating system targeting embedded devices. In versions prior to 24.10.6, a vulnerability in the hotplug_call function allows an attacker to bypass environment variable filtering and inject an arbitrary PATH variable, potentially leading to privilege escalation. The function is intended to filter out sensitive environment variables like PATH when executing hotplug scripts in /etc/hotplug.d, but a bug using strcmp instead of strncmp causes the filter to compare the full environment string (e.g., PATH=/some/value) against the literal "PATH", so the match always fails. As a result, the PATH variable is never excluded, enabling an attacker to control which binaries are executed by procd-invoked scripts running with elevated privileges. This issue has been fixed in version 24.10.6.
Affected products
- openwrt: before 24.10.6 — fixed in 24.10.6
How to fix
Upgrade to a fixed version: openwrt 24.10.6. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/openwrt/security/advisories/GHSA-jw28-hxcm-j934
- https://github.com/openwrt/procd/commit/e08cdc8562f55b9ac228a21f3f7605a18c522b81
Get alerted when CVE-2026-30874 or the next vulnerability affects your stack