What’s Vulnerable › Vulnerabilities

CVE-2026-30889: Discourse has Unauthorized Post Data Exposure in discourse-user-notes

Description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a moderator could exploit insufficient authorization checks to access metadata of posts they should not have permission to view. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-30889 or the next vulnerability affects your stack