What’s Vulnerable › Vulnerabilities
CVE-2026-30892: Crun incorrectly parses `crun exec` option `-u`, leading to privilege escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-269
Description
crun is an open source OCI Container Runtime fully written in C. In versions 1.19 through 1.26, the `crun exec` option `-u` (`--user`) is incorrectly parsed. The value `1` is interpreted as UID 0 and GID 0 when it should have been UID 1 and GID 0. The process thus runs with higher privileges than expected. Version 1.27 patches the issue.
Affected products
- containers crun: from 1.19 before 1.27 — fixed in 1.27
How to fix
Upgrade to a fixed version: containers crun 1.27. Check the vendor advisory for mitigations.
References
- https://github.com/containers/crun/commit/1bd7f42446999b0e76bc3d575392e05c943b0b01
- https://github.com/containers/crun/releases/tag/1.27
- https://github.com/containers/crun/security/advisories/GHSA-4vg2-xjqj-7chj
Get alerted when CVE-2026-30892 or the next vulnerability affects your stack