What’s Vulnerable › Vulnerabilities
CVE-2026-3091
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-427
Description
An uncontrolled search path element vulnerability in Synology Presto Client before 2.1.3-0672 allows local users to read or write arbitrary files and conduct denial-of-service during installation by placing a malicious DLL in advance in the same directory as the installer.
Affected products
- Synology Presto Client: before 2.1.3-0672 — fixed in 2.1.3-0672
How to fix
Upgrade to a fixed version: Synology Presto Client 2.1.3-0672. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3091 or the next vulnerability affects your stack