What’s Vulnerable › Vulnerabilities
CVE-2026-30923: libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-05 · updated 2026-07-25
- Weakness: CWE-125
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Libmodsecurity is one component of the ModSecurity v3 project. A segmentation fault occurs when a rule using the t:hexDecode transformation inspects a query string parameter containing a single character. An attacker can exploit this to crash worker processes, causing a denial of service. Service resumes once the attack stops as worker processes recover from the segfault. All versions before 3.0.15 of libModSecurity3 are affected. This has been patched in version 3.0.15.
Affected products
- owasp-modsecurity ModSecurity: before 3.0.15 — fixed in 3.0.15
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.15
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-qrjc-3jpc-3h2g
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-qrjc-3jpc-3h2g
Get alerted when CVE-2026-30923 or the next vulnerability affects your stack