What’s Vulnerable › Vulnerabilities
CVE-2026-30924: qui CORS Misconfiguration: Arbitrary Origins Trusted
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-942
Description
qui is a web interface for managing qBittorrent instances. Versions 1.14.1 and below use a permissive CORS policy that reflects arbitrary origins while also returning Access-Control-Allow-Credentials: true, effectively allowing any external webpage to make authenticated requests on behalf of a logged-in user. An attacker can exploit this by tricking a victim into loading a malicious webpage, which silently interacts with the application using the victim's session and potentially exfiltrating sensitive data such as API keys and account credentials, or even achieving full system compromise through the built-in External Programs manager. Exploitation requires that the victim access the application via a non-localhost hostname and load an attacker-controlled webpage, making highly targeted social-engineering attacks the most likely real-world scenario. This issue was not fixed at the time of publication.
Affected products
- autobrr qui: before 1.15.0 — fixed in 1.15.0
How to fix
Upgrade to a fixed version: autobrr qui 1.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/autobrr/qui/commit/424f7a0de089dce881e8bbecd220163a78e0295f
- https://github.com/autobrr/qui/security/advisories/GHSA-h8vw-ph9r-xpch
Get alerted when CVE-2026-30924 or the next vulnerability affects your stack