What’s Vulnerable › Vulnerabilities
CVE-2026-30925: Parse Server affected by Regular Expression Denial of Service (ReDoS) via `$regex` query in LiveQuery
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-1333
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.0-alpha.14 and 8.6.11, a malicious client can subscribe to a LiveQuery with a crafted $regex pattern that causes catastrophic backtracking, blocking the Node.js event loop. This makes the entire Parse Server unresponsive, affecting all clients. Any Parse Server deployment with LiveQuery enabled is affected. The attacker only needs the application ID and JavaScript key, both of which are public in client-side apps. This only affects LiveQuery subscription matching, which evaluates regex in JavaScript on the Node.js event loop. Normal REST and GraphQL queries are not affected because their regex is evaluated by the database engine. This vulnerability is fixed in 9.5.0-alpha.14 and 8.6.11.
Affected products
- parse-community parse-server: before 8.6.11; from 9.0.0 before 9.5.0; 9.5.0-alpha1, 9.5.0-alpha10, 9.5.0-alpha11, 9.5.0-alpha12, 9.5.0-alpha13, 9.5.0-alpha2 (+7) — fixed in 8.6.11, 9.5.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.11, 9.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.11
- https://github.com/parse-community/parse-server/releases/tag/9.5.0-alpha.14
- https://github.com/parse-community/parse-server/security/advisories/GHSA-mf3j-86qx-cq5j
Get alerted when CVE-2026-30925 or the next vulnerability affects your stack