What’s Vulnerable › Vulnerabilities
CVE-2026-30929: ImageMagick has a stack buffer overflow in MagnifyImage
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-121
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, MagnifyImage uses a fixed-size stack buffer. When using a specific image it is possible to overflow this buffer and corrupt the stack. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
Affected products
- ImageMagick: before 6.9.13-41; from 7.0.0-0 before 7.1.2-16 — fixed in 6.9.13-41, 7.1.2-16
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-41, 7.1.2-16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-30929 or the next vulnerability affects your stack