What’s Vulnerable › Vulnerabilities

CVE-2026-3093: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 14.0 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an attacker to execute arbitrary JavaScript in another user's browser via a crafted URL, due to improper sanitization of user-controlled input.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.5, 19.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3093 or the next vulnerability affects your stack